About SSL Certificates
 
 
Browser Requirements
Current Browser Information
Browser Unknown 0.0 - Not supported
JavaScript Supported
Cookies Supported
Security Click here to test if your browser is capable of establishing a secure web connection using 128 bit SSL encryption
 
 
Browser CARESnet is designed to work with the following browsers and versions:
  • Internet Explorer version 6.0 and higher
  • FireFox version 2.0 and higher
  • Safari version 2.0 and higher
  • Chrome version 1.0 and higher
How do I download the latest browser version?
 
JavaScript CARESnet requires that you have the JavaScript capabilities of your browser enabled.

How do I enable JavaScript?
 
Cookies CARESnet requires that you have Cookies enabled in your browser.

How do I enable cookies?
 
Security CARESnet requires a browser capable of 128 bit SSL encryption and requires SSL to be enabled to ensure the privacy and security of your CARESnet session.

How do I check if my browser supports 128 bit SSL and I have it enabled?

If you would like to download the latest version of Internet Explorer, Firefox, or Safari or if you need help to enable JavaScript, Cookies, or SSL security, please visit our Browser Requirements help page.